
1
a. Does the document have accessible file attachments? □ Yes / □ No / □ NA

b. Has this document being checked for accessibility using Adobe Acrobat Accessibility Checker? □ Yes / □ No / □ NA

c. Is the document an image-only or does it have scanned pages processed with Optical Character Recognition? □ Yes / □ No / □ NA

d. Is the document a tagged PDF? □ Yes / □ No / □ NA

2
a. Does the document have a good title? □ Yes / □ No / □ NA

b. Is Assistive Technology access, i.e., accessibility permission flag, enabled? □ Yes / □ No / □ NA

c. Is the document primary language set to the correct language, i.e., English? □ Yes / □ No / □ NA

d. Are the bookmarks present in large document? □ Yes / □ No / □ NA

3
a. Do the tags follow the visual / logical order of the document? □ Yes / □ No / □ NA

b. Does the document have decorative content that is set as background / artifact? □ Yes / □ No / □ NA

c. Is vital information in headers, footers, and watermarks duplicated in the document? □ Yes / □ No / □ NA

d. Are the headings in the document tagged with heading tags? □ Yes / □ No / □ NA

e. Are lists tagged correctly? □ Yes / □ No / □ NA

4
a. Do all images and other objects have an alternative text containing description of their purpose or function? □ Yes / □ No / □ NA

b. Do all data tables have programmatically identified headers and cells? □ Yes / □ No / □ NA

c. Do all links and controls have an unique identifiers, defined functions, and are they in tab order? □ Yes / □ No / □ NA

d. Do all form fields contain tool tips, has appropriate labels, and are they in tab order? □ Yes / □ No / □ NA

e. Are colors and sensory characteristics that convey information also duplicated in text? □ Yes / □ No / □ NA

f. Is the color contrast ratio between text and background is at least 4.5:1 (3:1 for large text 18pt / bold 14pt)? □ Yes / □ No / □ NA

g. Is the color contrast between neighboring colors in graphs or maps distinguishable? □ Yes / □ No / □ NA

h. Is the document free of any flashing objects? □ Yes / □ No / □ NA
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Instructions for the PDF Accessibility Checklist and 
Certification Form 
Preconditions 
1a. Does the document have accessible file attachments? 
Description: The benefit of attaching a file to a PDF, as opposed to using an external link, is that the 
attachment will travel with the PDF if you move it to a different location (e.g., a different folder or 
different server). 

How to Check: To view attachments, in top menu bar select View > Show/Hide > Navigation Panes > 
Attachments. 

 

1b. Has this document being checked for accessibility using Adobe Acrobat Accessibility 
Checker? 
How to Check: 

1) On the Tools pane (right pane), click “More Tools” to add “Accessibility” as a shortcut 
2) Click on “Accessibility” shortcut to expand Accessibility pane (also in the right) 
3) Click on “Accessibility Check” and click “Start Checking” with all Checking Options selected 
4) The result from accessibility check will show under Accessibility Checker pane (left pane) as well 

as an auto-generated report stored on your local machine for review 

1c. Is the document an image-only or does it have scanned pages processed with Optical 
Character Recognition? 
Description: The most fundamental component of PDF accessibility is ensuring that any text on the 
document is searchable. Screen readers and other assistive technologies are not able to read text from 
images or interpret the structure of documents that are saved as images. If you scan a document and 
save it as a PDF, you need to perform Optical Character Recognition (OCR) on it as a precursor to any 



additional accessibility checks. This article details how to perform OCR and provides tips on creating 
better quality document scans. 

How to Check: All or part of a PDF may be compiled from scanned pages. 

 

1d. Is the document a tagged PDF? 
Description: A key part of making PDFs accessible is ensuring the document is “tagged.” A “tagged PDF” 
is a type of PDF that includes an underlying tag tree, like HTML, that defines the structure of the 
document. 

How to Check: 

1. In top menu bar select File > Properties > Description (tab) and check for Advanced: Tagged PDF 
to show “Yes”. 

2. View > Show/Hide > Navigation Panes > Accessibility Checker > Document: Tagged PDF 



 

Document Properties 
2a. Does the document have a good title? 
Description: A descriptive title that identifies the document or its purpose helps everyone (including 
people with disabilities) locate, open, and switch between documents. 

How to Check: To view document properties, in top menu bar select File > Properties > Description (tab) 
for Title and Initial View for Show as Document Title. 

 



 

2b. Is Assistive Technology access, i.e., accessibility permission flag, enabled? 
Description: Setting the accessibility permission flag allows assistive technology such as screen readers 
to bypass certain security settings within a PDF. Screen readers need to be able to copy or extract a 
PDF's text to convert it to speech. 

How to Check: To view document properties, in top menu bar select File > Properties > Security (tab) 
and check for Document Restrictions Summary: Content Copying for Accessibility to be set to be 
allowed. 

 

2c. Is the document primary language set to the correct language, i.e., English? 
Description: The primary language of a document is important, as it tells the screen reader which 
language and pronunciation to use. 



How to Check: To view document properties, in top menu bar select File > Properties > Advanced (tab) 
and check for Reading Options: Language to be set to English. 

 

2d. Are the bookmarks present in large document? 
Description: Bookmarks are used in Adobe Acrobat to link a particular page or section of a PDF file. They 
allow you to quickly jump to that portion of the document by clicking on the linked phrase. 

How to Check: This test only applies to large document and contains bookmarks. To view bookmarks, in 
top menu bar select View > Show/Hide > Navigation Panes > Bookmarks. 

Structure Tags 
3a. Do the tags follow the visual / logical order of the document? 
Description: PDF tags are the key to accessing a PDF document’s content with assistive technologies 
such as screen readers. When a tagged PDF is created, each page element in the document is “tagged”. 
Each tag identifies the type of content and stores some attributes about it. They also arrange the 
document content into a hierarchical architecture (or a “tag tree”). The tag tree forms the logical 
structure of the document (reading order). The tag tree is comprised of the different tag types used 
within the document. Each document will have different tags depending on its content. Some examples 
are – Paragraphs, Headings, Lists, Tables, Figures, etc.  

Adding PDF tags does not change the visual appearance of the document; it provides invisible layer of 
formatting within the document that works with screen readers. PDF tags also allows the content to 
reflow seamlessly on devices with smaller screens, like smartphones and tablets. 



How to Check: Open Reading Order dialog to view tags highlighted on the document to determine how 
it is being structured. 

1) Enable the "Tags" pane. (View > Show/Hide > Navigation Panes > Tags). Enable "Highlight 
Content" from the "Tags" pane "Options" menu. 

 

 



2) Select the plus symbol on "Tags" to expand all tags. Press "Ctrl + A" to select all tags. Use the up 
and down arrow keys to move through the tags. 

 

3b. Does the document have decorative content that is set as background / artifact? 
Description: In the rare instance where an image adds no additional information to the screen's content, 
you can mark it as "decorative" and skip writing alt text. 

There are only two situations where an image can be considered decorative and therefore not need alt 
text. 

1. The image provides no important information or context. If an image conveys no important 
information necessary for the user to understand the page content, it can be considered decorative 
because its only function is to enhance the appearance of the page. 

2. The information in the image is repeated nearby on the page. If the exact information communicated 
by the image is available in an accessible, easily found format nearby on the same screen, it can be 
considered decorative because it provides no new information and would be redundant to include. 

How to Check: In the “Content” pane, Find Element, and then find all artifacts to determine these are 
correctly identified as decorative images.  Also, all images not classified as artifacts must have alt text. 



 

3c. Is vital information in headers, footers, and watermarks duplicated in the document? 
Description: Locate vital information, footers, and watermarks (e.g., Respond by X Date, CONFIDENTIAL, 
or DRAFT). Locate the first page or section to which the vital information applies. Highlight the second 
instance of the vital information on the same page. 

How to Check: In the “Tags” pane, find the tag corresponding to the vital information. (Tags pane > Find 
Tag from Selection). 

 

3d. Are the headings in the document tagged with heading tags? 
Description: Headings are used to break up content and make finding information easier. AT cannot 
infer meaning from just formatting, like bold or underline, so visual headings must correspond to a 
heading tag and heading tags (i.e., H1, H2, H3) must match the visual outline. 

How to Check:  



1) In the “Tags” pane, find the tag corresponding to heading to follow the visual outline. 

 
2) In the “Role Map” (Tags > Edit Role Map) to check non-standard heading tags mapped to the 

standard heading tags. 

 

3e. Are lists tagged correctly? 
Description: Screen readers cannot infer meaning from just symbols and indents. List tags create a 
structure that screen readers can identify. 

How to Check: Open the "Tags" pane and locate bulleted, numbered, or multilevel lists in the document. 
Highlight the list content and find its corresponding tag.  Verify that the highlighted content has a parent 
list tag 'L' and have one or more nested list item tags 'LI' under the parent 'L' tag. 



 

Objects 
4a. Do all images and other objects have an alternative text containing description of 
their propose or function? 
Description: Screen readers cannot infer meaning from images and other objects (pictures, images of 
text, charts, diagrams, shapes, icons with hyperlinks, etc.). Meaningful images must be accompanied by 
text that describes the purpose or function. 

Note: images that contain text (i.e., logos or agency seals) should have the text in the image included in 
the alternative or descriptive text. 

How to Check: 

1) View "Figures" (Tools > Accessibility > TouchUp Reading Order). Check "Show tables and figures"  



 
Right click the content tagged as "Figure" and select "Edit Alternate Text". All content tagged as 
"Figure" needs to have alternative text that describes its purpose or function. 

2) Find images / objects that have a caption describing the purpose or function of the image / 
object associated with it. 

3) Examine the surrounding content for text that describes the purpose or function of untagged 
(artifact) images. 

4b. Do all data tables have programmatically identified headers and cells? 
Description: Data tables in PDFs must be tagged as "Table". Column and row header cells must be 
tagged as "Table Headers". Tables containing multiple header rows, or cells that span multiple rows or 
columns, are complex tables and must have data / header associations to be accessible. 

How to Check: 

1) Locate programmatically identified data tables. Open the "Order" pane (View > Show/Hide > 
Navigation Panes > Order). 



 
2) Find all programmatically identified tables and check if table header cells are tagged as table 

headers. Open the "Order" pane (View > Show/Hide > Navigation Pane > Order) (Figure 24). 
Open the "Table Editor" (Right click on the table > Table Editor. Select "Show cell type (TH or 
TD)" checkbox). 

 
3) If the table is a complex table, right click each table cell and select "Table Cell Properties." For 

Header Cells check: 



a. "Header Cell" is checked 
b. Scope indicates "Column" or "Row" 
c. Attributes indicates correct "Row Span" and "Column Span" 
d. ID has a unique identifier 

 
4) If the table is a complex table, right click each table cell and select "Table Cell Properties." For 

Data Cells check: 
a. Data Cell is checked 
b. Associated Header Cell IDs are listed 

 



4c. Do all links and controls have an unique identifiers, defined functions, and are they in 
tab order? 
Description: While screen readers can read a full page to a user, screen reader users may prefer to 
instead listen to a list of links. In that case, a screen reader may only read the link text and not the 
surrounding text. 

Speech recognition software allows a user to avoid using a mouse. Users can speak the text of the link 
that they would like to follow. 

Keyboard-only users may not be able to use a mouse to click links. They use a keyboard’s tab button to 
navigate through a page’s links, buttons, and form inputs. For such users, it is very important for them to 
see which item has focus at all times. 

Colorblind users may not be able to perceive color cues. Typically, pages present links as a different 
color than their surrounding text. Adding underlines or other non-color indicators help users who may 
not see color. Users who are not comfortable with technology may also appreciate having links 
underlined. 

Links and controls must: 

1) Be uniquely identified 
2) Describe the destination, function, and/or purpose in the name or within context 
3) Be in a tab order that matches the visual/logical order of interactive elements (links, controls, 

and form fields) 

How to Check: Press the Tab key to find links and user controls. Check that each link has an 
unambiguous name that describes its destination, function, and/or purpose OR that this is determinable 
within context. For images that are a link or user control, the alt-text may contain the link purpose, 
function, or destination. 

Examples: 

1) Uniquely named link: Visit www.twdb.texas.gov for more information. 
2) Links determinable within context: For assistance, please look up contact information for your 

Regional Team. 
3) Ambiguous links not determinable within context: Click here to check our new manual. 

4d. Do all form fields contain tool tips, has appropriate labels, and are they in tab order? 
Description: It is necessary to provide instruction, directions, and cues for completing a form with 
assistive technology to enter information correctly and accurately in the appropriate fields. 

How to check: 

http://www.twdb.texas.gov/
http://www.twdb.texas.gov/contact/office/wsi.asp#rwpd
http://www.twdb.texas.gov/contact/office/wsi.asp#rwpd
http://www.twdb.texas.gov/publications/index.asp


1) All form fields must have a tooltip and the tool tip must match its label or instruction 

 
2) Press the Tab key to find form fields (text fields, radio buttons, checkboxes, combo boxes, etc.). 

The tab order must match the visual layout of the form. 

4e. Are colors and sensory characteristics that convey information also duplicated in 
text? 
Description: Using only color or other visual characteristics to convey meaning will not provide 
comparable access to people who are blind, have low vision, or are colorblind. 

How to check: Find where you have used color and/or other visual characteristics to convey meaning 
such as green, yellow, red, etc. 

  

4f. Is the color contrast ratio between text and background is at least 4.5:1 (3:1 for large 
text 18pt / bold 14pt)? 
Description: Color contrast is the difference in brightness between foreground and background colors. 
For accessibility purposes, aim for a 4.5:1 ratio between the foreground color (e.g. text, links, etc.) and 
the background color. This ratio ensures people with moderately low vision can tell the colors apart and 
see your content. 



How to Check: The Contrast Checker by WebAIM is a color contrast checker tool for this example. Click 
on either Foreground Color box to open color palette, click on eyedropper tool, and drag the eyedropper 
tool over a sample of your text or image of text and repeat the process with Background Color for the 
background. 

 

4g. Is the color contrast between neighboring colors in graphs or maps distinguishable? 
Description: The objective of this technique is to ensure people with moderately low vision can 
distinguish boundaries between adjoining segments of color. 

When selecting colors for graphics with multiple colors, consider adjoining colors and test that the 
contrast ratio is at least 3:1. If adjoining colors have less than 3:1 color contrast ratio difference add a 
border with at least a 3:1 color contrast with each color. 

How to Check: Measure the contrast ratio of each color compared to the adjacent color(s) or border (if 
present) to be at least 3:1. 

https://webaim.org/resources/contrastchecker/


4h. Is the document free of any flashing objects? 
Description: The TWDB do not typically see flashing objects embedded into documents. Since flashing 
objects may be a public safety issue for individuals with photosensitive epilepsy and there is not typically 
a compelling business need, flashing objects should be excluded. If you feel you do have a compelling 
business need, please contact us for assistance in ensuring your object flashes below 3Hz. 
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